Immortal conquest

Title: Can't access my account [Print this page]

Author: Deus    Time: 2019-1-25 20:19
Title: Can't access my account

I have an account on server 49 which was binded by Facebook.  I tried to log into it on an iPhone, but it didn't work.  When I returned to my android, it tried to make me start over.  It did not show a recent server and when I clicked onto 49, it tried starting over.  PLEASE help!!

Author: Server    Time: 2019-5-13 10:41
Edited by Server at 2019-5-13 10:45

I have the same problem, access in Facebook have, but I can not go to the account, it all started with the fact that I tried to log in with the iPhone and then lost access to the Android account too, tell me what to do, thanks in advance
Author: Mastereffef    Time: 2019-8-31 01:39
Title: Cant access my account
Hello guys,

Im a spanish user, sorry about my english.

My problem is that telnet dosent work. I cant connect to asus by telnet, but I have conection with workgroup of windows. I try to reset but nothing happens. I cant install moservice too. What can I do?

Thank you very much.
Author: youtubersuper    Time: 2019-11-10 15:13
Title: Cant access my account
Hey Im new in the website and I wanted to play the burger game forgot what was calledAnyways,I tried to play it after i made my account and I kept on clicking on the password box and I tried to type but it didnt show Anyways,have a good day
Author: youtubersuper    Time: 2019-11-14 17:29
Title: Cant access my account
But I was trying to join a server that has nine people. Also I cant join your server, I think its a problem with my side.

Edit: Making it sound sane.
Author: youtubersuper    Time: 2019-11-15 08:38
Title: Cant access my account
I made an account a while ago and played by myself because when ever I try joining a server it just says joining and Ive waited a while and it still says it Please help I really like this game and really want to play with my friends, if anyone knows the solution please tell me :
Author: fhgfrtryu    Time: 2019-12-13 00:47
Title: Cant access my account
hey thanks for the reply i have looked high and low at the FAQs and guides and my rep and everything like that seems to be in order so am really not sure whats stopping it from starting, i have even tried a plot reset but nothing...

Welcome to Immortal conquest ( Powered by Discuz! X3.3